
Rescue 95 Help Contents
      Rescue 95 is a program that will hopefully prevent you from ever having to reinstall Windows 95 again.
      The Registry is the central database that tells Windows 95 what to do and how to do it.    If you mess with it, or 
you install a program or driver that corrupts it, Windows 95 can be permanently crippled.    Usually the only 
recourse is to reinstall Windows 95, which takes around an hour, and then reinstall much of the hardware and 
drivers.
      Rescue 95 saves you from all of that.    Rescue 95 backs up and restores your Registry.    As an added feature, 
the Backup and Restore to Saved features restore other Windows initiation files, boot up files, and the Start Menu 
structure.    Within minutes Rescue 95 can have Windows95 back the way it was before problems arose.
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Dear Shareware Users,
This is the Shareware Version of Rescue 95.    Usually I put a 30 use limit on my shareware programs to

encourage registration.    But I did not want anyone to not be able to use this program in an emergency.    
Please take the time to repay my consideration and the time I have spent programming Rescue 95 by 
registering.    You may register by calling 1-800-242-4775 Ext. # 15136 or by going to our web site: 
http://members.aol.com/evanetten/rescue.htm.    

Registration is $19.95 + s&h.
Thank you,
Ray Geide
Super Win Software



How to Exit
There are three ways to get out of Rescue 95.

1.    Go up to the File menu and select Exit.

or

2.    Click on the "X" in the upper right hand corner of the Rescue 95 Window.

or

3.    Double click on the "cone" in the upper left hand corner.



How to Backup
As an added precaution, Rescue 95 allows you to save up to ten different Windows 

95 configurations.    If you do not save your configuration, you will probably still be able to 
restore Windows 95 using the Previous or Original options.

Rescue 95 does not save the current Registry configuration, but the previous loaded 
one.    The reason for this is that you often do not know that the Registry is bad until you 
start Windows 95 the next time.    If your current Windows 95 configuration is bad, DO NOT 
use the Save option.    Other than this, the Save option can be used safely at any time.

There are two ways to save or backup Windows 95.

1.    Click on the first button.    It says, "Backup Windows 95", "Save".

2.    Go to the Save menu and select "Backup".

When you select this option, a list box appears.    The current configuration to be 
saved will be shown as the current date.    You may change this to whatever you want.    
You may also change any of the titles of the other selections.    Click on the title and make 
any changes you desire.

Click on "OK" to make a backup and save the changes.
Clicking on "Cancel" will leave the list box without saving the current configuration.   

Any changes made to titles other than the most recent one will be saved.

If you already have ten selections, you will have to first delete at least one entry, 
press "OK", and then press "Save" again.



How to Restore
Rescue 95 provides you with three ways to restore the Registry of Windows 95.    If 

any of the backup files cannot be found, the corresponding Restore button is disabled and 
that option is not available.

It is recommended to start with one of the first two buttons.    Original should only be
used as a last resort.    Previous has the most recent configuration of the Registry, but 
Saved has a more complete backup.    

The buttons and options are as follows:

Previous
Every time you start Windows 95 the previous successful setup is saved.    Choosing 

this option will restore the Registry to the previous setup.    This may be all you need to do 
to restore the Registry.    If the copy process proceeded without error, Rescue 95 will 
automatically restart Windows.

This option is not fool proof.    Sometimes a faulty setup is not detected and is stored 
over a good one by Windows 95.

Saved
If you have previously backed up the Registry with Rescue 95, this option is 

available.    It allows you to restore any of ten previously saved configurations.
When you choose this option, a list box is shown.    Select one of the backups and 

press, OK.    The Registry will be restored to the selected configuration, corresponding 
initiation files, boot up files, and Start Menu will be restored, and Windows 95 will be 
restarted.

If Windows 95 restarts after selecting this option and is still faulty, select the next 
option, "Original".

Original
When Windows 95 is installed, the original configuration is stored in a special place.  

Rescue 95 seeks out this stored configuration and restores it to your computer.
This should only be done as a last resort.    You should even try using the MS DOS 

version of Rescue 95 before selecting this option.    
Using this option will cause the Registry to "forget" all of the programs and drivers 

that have been installed, even though they will still be on the hard drive.    You will be 
asked all of the user and configuration questions (for example, user name, password, time 
zone, etc.), and you will have to reinstall the programs and drivers that were registered in 
the Registry.

If for some odd reason, Rescue 95 can not find the stored original configuration, this 
button will be disabled.

If you accidentally choose this option and install the original configuration, you can 
undo most of it by running Rescue 95 and choosing Previous or Saved.

These three options are also available from the Rescue menu.



Getting Help
Two items are available from the Help menu:

1.    Contents - the files you are viewing now.

2.    About Rescue 95 - shows information about Rescue 95 and Super Win.

If you have questions that are not answered by these help files, please feel free to 
send your questions to: superwin@aol.com.



How to Restore in DOS 
(Emergency Rescue)

If Windows 95 will not restart and you cannot get to the Rescue 95 program, there is
a MS DOS version of Rescue 95 installed in the C directory.    It is "rescue.exe".

Only For Emergencies
This DOS program is only for emergency restoring.    Unlike the Windows version, it 

cannot backup the Registry or restore from other backups other than the most recent one.  
It also does not restore initiation files, boot up files, and the structure of the Start Menu, all
of which are saved by Rescue 95.    

For this reason, it is recommended that if you use the DOS version of Rescue 95 to 
restore from a "Saved" Configuration, that you also run the Windows version of Rescue 95 
and restore once more when you get into Windows 95.

How to Start the DOS Version
First, go to DOS.    Do this by pressing <F8> when the computer is starting and the 

message, "Starting Windows 95", is displayed.    Select from the list of options, "Command 
prompt only".

To run this program, go to the C directory, by typing the letter of the directory, C, 
followed by a colon and enter.

The DOS prompt should display only the drive letter without any other words.    If 
other words are present, type CD\ and enter.

Then type, RESCUE and enter to start the DOS Version

For example, in DOS type:

C:<ENTER> (that's three keys: "c", ":", and <ENTER>).    
CD\<enter> (that's four keys: "c", "d", "\", and <ENTER>).    
RESCUE<enter>.

WARNING: the DOS program, "attrib.exe" must be in the same directory as "rescue.exe".    The setup 
program has placed both into the root directory.    Without this rescue.exe will not be able to find your 
Windows Directory when you boot up with the Windows95 bootup diskette.

Restore Options
If the correct option is not selected, use <TAB> to move to the Restore options.    

Once one of the three options is active, use the arrow keys to change.

Windows 95 Directory
Check the listed Windows 95 Directory.    If it is not correct, use <TAB> to activate it, 

and type in the correct directory.

WARNING - If you get an error message that the Windows Directory is not specified and you know that you 
have declared the correct directory, it is probably because the "attrib.exe" file is not in the same directory 
as the "rescue.exe" file.    Copying attrib.exe to the directory of rescue.exe will solve this problem.    
Attrib.exe is on the bootup diskette.

Reconfigure or Exit
Reconfigure will start the restoration process and then restart Windows.    Exit will 

quit the program without doing anything.    Use <TAB> to go to one of these buttons and 
<ENTER> to select them.





Prompt
Prompt is a menu item.    You are given a choice of never, daily, weekly, and monthly.

If one of the last three option is chosen (daily, weekly, monthly) a program is placed in the 
Start Up directory that will run Rescue 95 at the interval specified when Windows95 is 
started.    If you choose "never", Rescue 95 will delete the program in the Start Up menu (if
it is there) and Rescue 95 will only be run when you choose to run it.

For example, if you choose monthly, every 30 days when you start Windows 95, 
Rescue 95 will begin.    The only option you will be given is the Save or Backup option.    
Once the Registry is saved, Rescue 95 will quit.

It is not necessary to save Windows 95 daily unless you install and change the 
settings of the Registry frequently every day.



How does Rescue 95 Work?
The Backup Feature Does NOT:

Enter the Registry or change the Registry in any way.
Alter files used by the Registry.    
Save any of the Windows 95 program files.
Backup any other program files.

The Backup Feature Does:
Copy the SETUP BACKUP files used by the Registry (see the list of files below).
Copy other INITIATION files used by Windows 95.
Copy BOOT UP files used by DOS.
Record the titles of top level directories and top level files in the Start Menu.
Allow up to 10 different Backups.

Explanation of the Backup Process
Types of Files used by Rescue 95 (see specific file names at the bottom)

SETUP (Registry) - current configuration of the Registry
SETUP BACKUP (Registry) - previous "successful" configuration
ORIGINAL BACKUP (Registry) - original configuration of the Registry
INITIATION (Windows) - Windows 3.1 type configuration used by Windows95
BOOT UP (DOS) - DOS boot up files used by Windows95
START MENU (Windows95) - top level structure of the Start Menu
RESCUE BACKUP (Rescue 95) - copies of SETUP BACKUP, INITIATION, BOOT UP, and START MENU

There are SETUP files that the Registry uses to set itself up.    These files are hidden 
and may not be directly accessible to the user.    Each time Windows 95 starts successfully,
it makes a set of SETUP BACKUP files, copying over the previous SETUP BACKUP files.    
There are also INITIATION files that Windows 95 consults, BOOT UP files that Windows95's 
DOS uses when starting, and Rescue 95 makes a START MENU file listing the top level 
structure of the Start Menu.    The backup process of Rescue 95 finds these files, duplicates
them in their entirety, and renames the copies (with the endings ray, ra0, ra1, and etc.).    
The original files are not altered.

Explanation of the Restore Process
When Rescue 95 restores the Registry it copies files to the currently used SETUP 

files.    Which files are copied depends on which Restore Option is selected.
If "Previous" is selected the SETUP BACKUP files are copied over the SETUP files.      

WARNING: Windows 95 does not always detect a faulty setup before these files are copied, so the SETUP 
BACKUP files may become defective. 

Although this option provides the most recent configuration of Windows 95, sometimes it 
does not work.

If "Saved" is selected the RESCUE BACKUP files are copied over the SETUP, 
INITIATION, and BOOT UP files.    The START MENU file is consulted to find and delete top 
level directories and files that have been added since the backup.    If you regularly use 
Rescue 95 to backup Windows 95, this is the best way to restore Windows 95.

If "Original" is selected the ORIGINAL SETUP file is copied over the SETUP file.    If all 
else fails (which it shouldn't, unless you have not used Rescue 95 to create good backups),
you are given this option to go back to the original setup of Windows 95.    This is just as if 
you reinstalled Windows 95, without spending an hour doing it.    You will be asked all of 
the setup questions, like, user name, password, time zone, and etc.

If the copying process is successful, Windows is restarted.

Files Used by Rescue 95



The Registered Version of Rescue 95 lists all the filenames used by Rescue 95 and Windows 95.



How to Change Default Directories
Sometimes Windows95 does not use the default directories.    For example, foreign 

versions of Windows 95 may call the Start Up menu by a different name, or multiusers 
may have files in different directories.

Rescue 95 allows the user to specify four directories: the root directory, the startup 
menu, the directory of system.dat, and the directory of user.dat.

WARNING - DO NOT change the Default Directories if you do not need to.    Rescue 95 will not work when 
the wrong directories are specified.

Change a Directory

To change a directory, go to the File menu, then to "Directory Settings".    Go to the 
directory you wish to change and select "Browse".    This will display a dialog box from 
which you may find the directory you want.    To select the directory you must click on a file
in the desired directory.    If no file is listed in the directory, it is because the needed file is 
not there.    

The only exception to this is the Start Up directory which does not need a file in it to 
select it.

Select "Open" to save the new directory or "Cancel" to ignore the changes.

Change Back to the Default directory

To change back to the Default directory, go to the File menu, then to "Directory 
Settings".    Go to the directory you wish to change and select "Default Directory".



How to Select What is Restored
Rescue 95 allows the selection and deselection of files to be restored.    For example,

if you only want to restore the bootup files, you may deselect the other selections and 
then press the "Saved" button.    Only the bootup files will be restored.

Look in the File Menu

These selections are found in the File Menu.    Place the cursor over "Rescue 
Settings".    Four settings will be shown:    Registry Files, Initiation Files, Bootup Files, and 
Start Menu.    When Rescue 95 is started all of them will have checkmarks next to them 
and are thus selected.    Clicking on a checked selection will uncheck it.    Clicking on an 
unchecked selection will check it.

These selections will not be saved when you quit Rescue 95.    So the next time you 
start Rescue 95, all the "Rescue Settings" will be checked.

Only with Restore Saved

This feature only works when restoring to a previously backed up configuration. 
When Restore Saved from the Rescue Menu or the Saved button is clicked a list of 

previously saved configurations are shown.    When you select one and click on OK, the 
files that are checked in "Rescue Settings" are restored to those that were previously 
saved and Windows 95 is restarted.

These "Rescue Settings" do not effect what is backed up (all of these files are always
backed up) or the Restore Original or Restore Previous options.    Restore Original and 
Restore Previous only restore the Registry Files.

After restoring, Windows 95 will always be restarted.



WARNING - Files Could Not Be Copied
After a Backup or Rescue, a dialog box may appear stating, "The following file(s) 

could not be copied".    One or more files will be listed. 
Most probably Rescue 95 could not find the listed file(s).    The reason why the file 

could not be found may be because your system does not use them.    If this is the case, 
you may select Yes to restart Windows.

Another reason why Rescue 95 cannot find a file may be that you accidently deleted 
it.    You may be able to correct this by performing the opposite operation in Rescue 95.    
For example, if a file is missing when you perform a Rescue, then deleting that icon from 
the list and performing a Save should correct it and vice versa.

Yet, another reason may be that the directory settings are wrong.
Go to "Directory Settings" in the File Menu to make the neccessary corrections.

If files containing the word, "system" or    "user" could not be copied, do NOT restart 
Windows until you have corrected the problem.        






